Índice do fórum Treinamentos Avançados Treinamento Oracle RAC PRVF-5150: Path /dev/asm* is not a valid path on all nodes

PRVF-5150: Path /dev/asm* is not a valid path on all nodes

Dúvidas, dicas e atualizações sobre o Treinamento Oracle RAC.


Mensagens: 0
Bom dia,

Estou com um problema para instalar o Oracle RAC 11.2.0.4 no AIX 7.1 64.
O erro (anexo) ocorre na etapa de verificação dos pré-requisitos:
PRVF-5150: Path /dev/asm_voting1 is not a valid path on all nodes.

As permissões estão como 660 e o dono é oracle e grupo dba.
Nenhuma das LUNs está passando nessa verificação. Encontrei no Metalink um Bug relacionado, porém só para a versão 11.2.0.2 e disse que está corrigido na 11.2.0.3. O Note do Bug dizia para ignorar os erros e prosseguir a instalação. Fiz o mesmo para ver se funcionava e deu erro na instalação.

Alguém já passou por isso?

Abraços,

Franky
Anexos
Screen Shot 2014-12-02 at 6.07.15 PM.png
oui_gi-check
Screen Shot 2014-12-02 at 6.07.15 PM.png (173.08 KiB) Exibido 2809 vezes

portilho Site Admin

Mensagens: 444
Oi.
Verifique estas características dos discos:

To enable simultaneous access to a disk device from multiple nodes, you must set the appropriate Object Data Manager (ODM) attribute, depending on the type of reserve attribute used by your disks. The following section describes how to perform this task using hdisk logical names. Refer to your operating system documentation to find logical device names.

To determine the reserve setting your disks use, enter the following command, where n is the hdisk device number:

# lsattr -E -l hdiskn | grep reserve_

The response is either a reserve_lock setting, or a reserve_policy setting. If the attribute is reserve_lock, then ensure that the setting is reserve_lock = no. If the attribute is reserve_policy, then ensure that the setting is reserve_policy = no_reserve.


Mensagens: 0
Obrigado mais uma vez, Portilho.
Essa configuração aí o pessoal do AIX já tinha feito. Consegui instalar definindo as permissões 666 para as LUNs.
Hoje cedo instalando o Database na hora de listar os nodes do RAC os mesmos não apareciam na lista e ao avançar ocorria um erro que dizia para iniciar o Cluster com "crsctl start crs", porém os dois nodes já estavam online.
Buscando no metalink encontrei um note 1053393.1, o que sugere alterar o arquivo inventory.xml através do runInstaller com os parâmetros:
runInstaller -updateNodeList ORACLE_HOME="/u01/app/11.2.0/grid" CRS=true

Fazendo isso os nodes apareceram e minha instalação finalizou com sucesso.

Abraços,

Franky

portilho Site Admin

Mensagens: 444
Obrigado pela atualização a respeito da Nota, Franky.
Estranho essa necessidade do 666. :-D

Abraço !


Voltar para Treinamento Oracle RAC